re = /(?:'|\")\${(\d):.*?}(?:'|\")/
str = 'import configparser
configIni = configparser.ConfigParser()
configIni.read(\'${1:example.ini}\')configIni.read(\'${2:example2.ini}\')'
subst = '$\\g<1>$'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result