// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?:'|\")\${(\d):.*?}(?:'|\")"#).unwrap();
let string = "import configparser
configIni = configparser.ConfigParser()
configIni.read('${1:example.ini}')configIni.read('${2:example2.ini}')";
let substitution = "$\\g<1>$";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}