const regex = /^(?=(?:\+|0{2})?(?:(?:[\(\-\)\t\f ]*\d){7,10})?(?:[\t\f ]?\d{2,3})(?:[\-\s]?[ext]{1,3}[\-\t\f ]?\d{1,4})?$)((?:\+|0{2})\d{0,3})?(?:[\-\t\f ]?)(\(0?\d{1,3}\)|\d{0,3})(?:[\-\t\f ]{0,2}\d){3,}(?:[\-\s]?(?:x|ext)[\-\t\f ]?(\d{1,4}))?$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(?:\\+|0{2})?(?:(?:[\\(\\-\\)\\t\\f ]*\\d){7,10})?(?:[\\t\\f ]?\\d{2,3})(?:[\\-\\s]?[ext]{1,3}[\\-\\t\\f ]?\\d{1,4})?$)((?:\\+|0{2})\\d{0,3})?(?:[\\-\\t\\f ]?)(\\(0?\\d{1,3}\\)|\\d{0,3})(?:[\\-\\t\\f ]{0,2}\\d){3,}(?:[\\-\\s]?(?:x|ext)[\\-\\t\\f ]?(\\d{1,4}))?$', 'g')
const str = `123456789
1234567890123456
1234567890123
(0)123456789
+34123456789
+34 (0)123456789
+340123456789
+34 123 456 789
+34 1 23 45 67 89
001230123456789
ext1234
++34123456789
00-0-----000
01 555012345
001-555012345
+012345678
911
112
12(34567890
123)456789012345
0091234567890
+9 123-4567890-x321
+9-123-456-7890
+9 123 4 5 6-7890x1234
009-(123)-456-7890 ext4321
0091234567890x1234
+9-123-456-7890x12345
+9-123-456-7890 ext 1234
0027-123-456-7890
+27-123-456-7890
+9(123)4567890
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}