# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=(?:\+|0{2})?(?:(?:[\(\-\)\t\f ]*\d){7,10})?(?:[\t\f ]?\d{2,3})(?:[\-\s]?[ext]{1,3}[\-\t\f ]?\d{1,4})?$)((?:\+|0{2})\d{0,3})?(?:[\-\t\f ]?)(\(0?\d{1,3}\)|\d{0,3})(?:[\-\t\f ]{0,2}\d){3,}(?:[\-\s]?(?:x|ext)[\-\t\f ]?(\d{1,4}))?$"
test_str = ("123456789\n"
"1234567890123456\n"
"1234567890123\n\n"
"0091234567890\n"
"+9 123-4567890-x321\n"
"+9-123-456-7890\n"
"+9 123 4 5 6-7890x1234\n"
"009-(123)-456-7890 ext4321\n"
"0091234567890x1234\n"
"+9-123-456-7890x12345\n"
"+9-123-456-7890 ext 1234\n"
"0027-123-456-7890\n"
"+27-123-456-7890\n"
"+9(123)4567890\n"
"911\n\n"
" (0)123456789\n"
"+34123456789\n"
"+34 (0)123456789\n"
" +340123456789\n"
"+34 123 456 789\n"
"+34 1 23 45 67 89\n"
"001230123456789\n"
"ext1234\n"
"++34123456789\n"
"00-0-----000\n"
"01 555012345\n"
"001-555012345\n"
"+012345678\n"
"112\n"
"12(34567890\n"
"123)456789012345\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.