#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([\]\)]),(\s*\n*\s*)([\]\)])"
Local $sString = "[[" & @CRLF & _
" 'id' => 'palette-3'," & @CRLF & _
"" & @CRLF & _
" 'color1' => [ 'color' => '#3eaf7c' ]," & @CRLF & _
" 'color2' => [ 'color' => 'rgb(207, 216, 225)' ]," & @CRLF & _
" 'color3' => [ 'color' => '#f0f0f0' ]," & @CRLF & _
" 'color4' => [ 'color' => '#c8c8c8' ]," & @CRLF & _
" 'color5' => [ 'color' => '#f0f0f0' ]," & @CRLF & _
" " & @CRLF & _
" ]," & @CRLF & _
"]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")