import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\]\\)]),(\\s*\\n*\\s*)([\\]\\)])";
final String string = "[[\n"
+ " 'id' => 'palette-3',\n\n"
+ " 'color1' => [ 'color' => '#3eaf7c' ],\n"
+ " 'color2' => [ 'color' => 'rgb(207, 216, 225)' ],\n"
+ " 'color3' => [ 'color' => '#f0f0f0' ],\n"
+ " 'color4' => [ 'color' => '#c8c8c8' ],\n"
+ " 'color5' => [ 'color' => '#f0f0f0' ],\n"
+ " \n"
+ " ],\n"
+ "]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}