Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
([\]\)]),(\s*\n*\s*)([\]\)])
/
gm
Test String
New
[[ 'id' => 'palette-3', 'color1' => [ 'color' => '#3eaf7c' ], 'color2' => [ 'color' => 'rgb(207, 216, 225)' ], 'color3' => [ 'color' => '#f0f0f0' ], 'color4' => [ 'color' => '#c8c8c8' ], 'color5' => [ 'color' => '#f0f0f0' ], ], ]