package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^<\s*(?<Slash>/\s*)?(?<TagName>(?:esi:)?[a-zA-Z0-9-]+)(?<AttrList>[^>]*)>?$`)
var str = `<input src>
<esi:include src>
<esi:include src/>
<esi:include src />
<esi:include src="http://example.com/1.html" alt="http://bak.example.com/2.html" onerror="continue"/>
<p>
</p>
<esi:in:clude src/>
<esi::include src/>
<esi::::::::::include src>
<:::::::::esi:include src>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}