# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[\w ]+ main\([\w ]*\){(?P<body>(?:\n|.)+)}/${body}/g;t' <<< "int main(void){
//printf test //
a = 5
if a{
printf(a)
}
if a{
printf(\"printf\")
}
}"