using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w ]+ main\([\w ]*\){(?P<body>(?:\n|.)+)}";
string substitution = @"${body}";
string input = @"int main(void){
//printf test //
a = 5
if a{
printf(a)
}
if a{
printf(""printf"")
}
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}