// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)^(?<wave>[1-9AE]|1[0-4])(?<variable>\w+)").unwrap();
let string = "3educ
Aage
14abc
Ekajshklasjf
Zljhfksdfj";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}