using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"^\w+(\.[\w-]+)*@([\w-]+\.)*\w([\w-]+\.)+[\w-]+$";
        string input = @"lqw0@xs4dys3.ugch
aybg6_o2u@5h3ldf2.owu
1qq@o9ktoel7r5i.bhe
bvp3wvq@p1idtm.yk
ppc@ebur3k8dz7x5oto.lxux
8nvy76@xd2mxvenu4n.hl
0im5l20bpre7lqce6@s8pz941v.au
rc@bmn4n.da
i6altyo3@zcvv3383f.tvhg
njvg@71ya.scof";
        RegexOptions options = RegexOptions.Multiline;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}