# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[([^]]+)\]/$1/gm;t' <<< "
select
1 as [test]
from [dbo].[weirdTable]"