$re = '/^(.)\1{7}/m';
$str = 'oooooooo34reefe aaaaaaaafsfdew4regr4 llllllllsftgerf qqqqqqqqdhiocdnsfncdops';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);