#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\".*\\(.+)[\r\n](.*)\""
Local $sString = ""c:\users\jdoe\OneDrive\Folder 1\Folder 2\File 1.pdf" & @CRLF & _
"File 1.pdf"" & @CRLF & _
""c:\users\jdoe\OneDrive\Folder 1\Folder 2\File 2.pdf" & @CRLF & _
"File 2.pdf""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")