// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\".*\\(.+)[\r\n](.*)\""#).unwrap();
let string = "\"c:\\users\\jdoe\\OneDrive\\Folder 1\\Folder 2\\File 1.pdf
File 1.pdf\"
\"c:\\users\\jdoe\\OneDrive\\Folder 1\\Folder 2\\File 2.pdf
File 2.pdf\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}