re = /<(?P<tname>[^\s]+)[^>]*?\stype\s*=\s*(?P<q>[\x22\x27])yaml(?P=q)((?!<\/(?P=tname)).+?)!ruby/
str = '<a type="yaml" !ruby'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end