re = /^(?:\([^)]*\)\s*([^(\r\n]*?)\s*\([^)]*\)|\[[^\]]*\]\s*([^(\r\n]*?)\s*\[[^\]]*\])\.(.*)$/m
str = '(garbage info) filename (other garbage).extension
[garbage info] filename [other garbage].extension'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end