using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*(byte|short|int|long|float|double|char|boolean|[A-Z][a-zA-z]+)\s*(\[\])*\s+([\w]+)\s*((,\s*[\w]+)*)\s*;";
string input = @"
int a, ss, f ;
char g;
byte f_123 ; double pi;
String string;
Object[] array1;
int [] array2, array3;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}