const regex = /\s*(byte|short|int|long|float|double|char|boolean|[A-Z][a-zA-z]+)\s*(\[\])*\s+([\w]+)\s*((,\s*[\w]+)*)\s*;/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*(byte|short|int|long|float|double|char|boolean|[A-Z][a-zA-z]+)\\s*(\\[\\])*\\s+([\\w]+)\\s*((,\\s*[\\w]+)*)\\s*;', 'gm')
const str = `
int a, ss, f ;
char g;
byte f_123 ; double pi;
String string;
Object[] array1;
int [] array2, array3;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}