#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^2(([0-5]\d{2})|([6-8](([1][9])|([2-9]\d)))|([9](([2][1-9])|[3-9]\d)))$"
Local $sString = "2600" & @CRLF & _
"2599" & @CRLF & _
"1999" & @CRLF & _
"2000" & @CRLF & _
"2618" & @CRLF & _
"2619" & @CRLF & _
"2899" & @CRLF & _
"2900" & @CRLF & _
"2921" & @CRLF & _
"2920" & @CRLF & _
"2999" & @CRLF & _
"3000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")