$re = '/^(?!.*\/products(?:\/))(?:(.*)\/|$)?(?:child)$/m';
$str = 'https://products.domain.com/products/
https://products.domain.com/products/family/child
https://products.domain.com/family/children
https://products.domain.com/products/family/children
https://products.domain.com/family/child';
$subst = "$1/children";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;