$re = '/("Premier_Support__c":)(.*?)(,)/m';
$str = '{"searchRecords":[{"attributes":{"type":"Account","url":"/services/data/v43.0/sobjects/Account/001e000001CVMfNAAX"},"Id":"001e000001CVMfNAAX","Phone":"(781) 248-1820","Premier_Support__c":true,"Parent":null},{"attributes":{"type":"Contact","url":"/services/data/v43.0/sobjects/Contact/003e000000w8fo9AAA"},"Id":"003e000000w8fo9AAA","Phone":"(781) 248-1820","Account":{"attributes":{"type":"Account","url":"/services/data/v43.0/sobjects/Account/001e000001CVMfNAAX"},"Premier_Support__c":true,"Parent":null}}]}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);