#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^)(?:tomcat|vizql|hs_err|tdeserver64|tabprotosrv|nativeapi)(?:.*)(?:\.log|\.txt)$"
Local $sString = "tabprotosrv_backgrounder_0-0.txt" & @CRLF & _
"tomcat.log"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")