using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^)(?:tomcat|vizql|hs_err|tdeserver64|tabprotosrv|nativeapi)(?:.*)(?:\.log|\.txt)$";
string input = @"tabprotosrv_backgrounder_0-0.txt
tomcat.log";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}