import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(personal-trainers|fysiotherapeuten)(\\/pagina\\/([0-9]+))?\\/?(\\?([a-zA-Z0-9.-=&]+))?\\/?";
final String string = "personal-trainers/?latitude=52.1816907&longitude=5.9587436&specialisme=1&trainings=0\n"
+ "http://localhost:8080/personal-trainers/?latitude=52.1816907&longitude=5.9587436&specialisme=1&trainings=0\n"
+ "http://localhost:8080/personal-trainers/pagina/2/?latitude=52.1816907&longitude=5.9587436&specialisme=1&trainings=0";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}