#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(hello)\n*(world)"
Local $sString = " a0" & @CRLF & _
" b0" & @CRLF & _
" c0" & @CRLF & _
"hello" & @CRLF & _
" a1" & @CRLF & _
" b1" & @CRLF & _
" c1" & @CRLF & _
"world" & @CRLF & _
"more..." & @CRLF & _
"hello" & @CRLF & _
" a2" & @CRLF & _
" b2" & @CRLF & _
" c2" & @CRLF & _
"world" & @CRLF & _
" a3" & @CRLF & _
" b3" & @CRLF & _
" c3" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")