import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<ipaddress>[^\\s]+)\\s-\\s.*\\s\\[.*\\]\\s\"\".*\"\"\\s2[0-9][0-9]\\s[0-9]*\\s\"\"-\"\"\\s\"\".*\"\"\\s\"\".*\"\"[^\\n]*$";
final String string = "123.456.789.01 - - [28/Apr/2024:08:44:37 +0200] \"GET /folder1/file HTTP/1.1\" 200 368 \"-\" \"python-requests/2.25.1\" \"-\"\n"
+ "123.456.789.01 - - [28/Apr/2024:09:47:34 +0200] \"GET /folder1/file HTTP/1.1\" 200 312 \"https://www.came-from-here.abcd/\" \"Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0\" \"-\"\n"
+ "123.456.789.01 - SillyUserName [28/Apr/2024:13:18:12 +0200] \"GET /folder2/Start.html HTTP/1.1\" 200 10269 \"https://www.came-from-there.abcd/folder2/start.html\" \"Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0\" \"-\"\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}