use strict;
my $str = '123.456.789.01 - - [28/Apr/2024:08:44:37 +0200] "GET /folder1/file HTTP/1.1" 200 368 "-" "python-requests/2.25.1" "-"
123.456.789.01 - - [28/Apr/2024:09:47:34 +0200] "GET /folder1/file HTTP/1.1" 200 312 "https://www.came-from-here.abcd/" "Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0" "-"
123.456.789.01 - SillyUserName [28/Apr/2024:13:18:12 +0200] "GET /folder2/Start.html HTTP/1.1" 200 10269 "https://www.came-from-there.abcd/folder2/start.html" "Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0" "-"
';
my $regex = qr/^(?<ipaddress>[^\s]+)\s-\s.*\s\[.*\]\s"".*""\s2[0-9][0-9]\s[0-9]*\s""-""\s"".*""\s"".*""[^\n]*$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}