// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mi)^(?<ipaddress>[^\s]+)\s-\s.*\s\[.*\]\s"".*""\s2[0-9][0-9]\s[0-9]*\s""-""\s"".*""\s"".*""[^\n]*$"#).unwrap();
let string = "123.456.789.01 - - [28/Apr/2024:08:44:37 +0200] \"GET /folder1/file HTTP/1.1\" 200 368 \"-\" \"python-requests/2.25.1\" \"-\"
123.456.789.01 - - [28/Apr/2024:09:47:34 +0200] \"GET /folder1/file HTTP/1.1\" 200 312 \"https://www.came-from-here.abcd/\" \"Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0\" \"-\"
123.456.789.01 - SillyUserName [28/Apr/2024:13:18:12 +0200] \"GET /folder2/Start.html HTTP/1.1\" 200 10269 \"https://www.came-from-there.abcd/folder2/start.html\" \"Mozilla/5.0 (X11; Linux x86_64; rv:109.0) Gecko/20100101 Firefox/115.0\" \"-\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}