$re = '/\\\\\\\\TABASIPP\\\\Prod_Data\\\\appr\\\\data\\\\(?<date>\d\d\d\d-\d\d-\d\d)/m';
$str = '\\\\TABASIPP\\Prod_Data\\appr\\data\\2022-06-01';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);