#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\n[-:;=""\/\.\sa-zA-Z]+\n\n"
Local $sString = "" & @CRLF & _
"Content-Disposition: form-data; name="file"; filename="test.jpg"" & @CRLF & _
"Content-Type: image/jpeg" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"тут тело картинки" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")