using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\n[-:;=""\/\.\sa-zA-Z]+\n\n";
string input = @"
Content-Disposition: form-data; name=""file""; filename=""test.jpg""
Content-Type: image/jpeg
тут тело картинки
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}