import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n[-:;=\"\"\\/\\.\\sa-zA-Z]+\\n\\n";
final String string = "\n"
+ "Content-Disposition: form-data; name=\"file\"; filename=\"test.jpg\"\n"
+ "Content-Type: image/jpeg\n\n\n"
+ "тут тело картинки\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}