re = /\n[-:;=""\/\.\sa-zA-Z]+\n\n/i
str = '
Content-Disposition: form-data; name="file"; filename="test.jpg"
Content-Type: image/jpeg
тут тело картинки
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end