import re
regex = re.compile(r"\[\[Kategória:[^\]\]]+\]\]", flags=re.MULTILINE)
test_str = ("[[Kategória:Rakúski anarchisti]]\n"
"[[Kategória:Rakúski filozofi]]\n"
"[[Kategória:Osobnosti z Viedne]]\n"
"[[Kategória:Rakúski automobiloví pretekári|F1]]\n"
"[[Kategória:Rakúski športovci|Automobiloví pretekári]]\n"
"[[Kategória:Automobiloví pretekári podľa štátu|Rakúsko]]\n\n"
"[[Kategória: ]]\n"
"<comment>-[[Kategória:Literárne žánre]]; -[[Kategória:Filmové žánre]] pomocou použitia HotCat</comment>\n"
"<comment>+[[Kategória:Zaniknuté monarchie]]; +[[Kategória:Zaniknuté štáty Európy]]; +[[Kategória:Zaniknuté štáty Ázie]] pomocou použitia HotCat[[Kategória: ]]</comment>\n"
"<comment>odobratá [[Kategória:Dvojtisícovky]]; pridaná [[Kategória:Dvojtisícovky na Slovensku]] pomocou použitia HotCat</comment>\n"
"<comment>-[[Kategória:Technika]]; ±[[Kategória:Biológia]]→[[Kategória:Akvaristika]] pomocou použitia HotCat</comment>\n"
"<comment><!-- [[Kategória:Civilizácia]] -->, [[Kategória:Civilizácie]]</comment>\n"
"[[Kategória:User fa|{{PAGENAME}}]][[Kategória:User fa-N|{{PAGENAME}}]] &#1586;&#1576;&#1575;&#1606; &#1605;&#1575;&#1583;&#1585;&#1740; &#1575;&#1740;&#1606; &#1705;&#1575;&#1585;&#1576;&#1585; &#1575;&#1587;&#1578;</span><hr/><span style="font-size: 8pt;">This user is a native speaker of '''[[:Kategória:User fa|Persian]]'''.</span>\n\n"
"odobratá [[Kategória:Osobnosti z Málagy]]; pridaná [[Kategória:Osobnosti z Malagy]]\n\n"
"Toto nechceme:\n"
"Taktiež môžete zaradiť článok do tzv. kategórie s ostatnými súvisiacimi článkami. Stačí ak napíšete <nowiki>[[Kategória:]]</nowiki> a názov kategórie medzi dvojbodku a hranaté zátvorky. Viac informácií nájdete na stránke o [[Wikipédia:Kategórie|kategóriách]].\n\n\n"
"1. I have a two pets - dog and a cat\n"
"2. I have a pet - dog")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")