#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)(?msi)step start.*?database:dev.*?step end"
Local $sString = "step start" & @CRLF & _
" name:step1" & @CRLF & _
" database:dev1" & @CRLF & _
"step end" & @CRLF & _
"step start" & @CRLF & _
" name:step2" & @CRLF & _
" database:test1" & @CRLF & _
"step end" & @CRLF & _
"step start" & @CRLF & _
" name:step3" & @CRLF & _
" database:dev2" & @CRLF & _
"step end" & @CRLF & _
"step start" & @CRLF & _
" name:step4" & @CRLF & _
" database:test2" & @CRLF & _
"step end"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")