$re = '/\bwin(?:dows)?(?:\s+server)?(?:\s*(?:200[38]|201[269]))?\b/m';
$str = 'microsoft windows 2016
win2016
win2012
windows 2012
windows server 2012
windows server 2008 r2
windows server 2008
windows 2019
windows 2012 r2 std
win2003
windows server 2003
windows 2003';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);