package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\bfield\[|\]\[|([^\]]+)`)
var str = `a[cat][dog]field[somevalue][anothervalue][other][some][aaa][bbb]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}