$re = '/(?<=:)(\d+):(\d+):(\d+)/';
$str = '10/Jun/1998:16:21:03 +0000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);