using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*?)\/(?<mnemonic>.{2,8}?)_(?<isbn>\d{13})_(?<primaryId>.+?)_(?<secondaryId>(\d{1,2}|x)p)(?:_r(?<revisionNumber>\d+))?\.(?<extension>indd|qxp|qxd)$";
string input = @"Obam_9781524763138_all_7p_r3 Folder/ObamObamObam_9781524763138_all_0p_r3.indd
Obam_9781524763138_all_7p_r3 Folder/Ob_9781524763138_all_0p_r3.indd
Obam_9781524763138_all_7p_r3 Folder/Obam_9781524763138_all_0p_r3.indd
Obam_9781524763138_all_7p_r3 Folder/Obam_9781524763138_all_77p_r3.indd
Obam_9781524763138_all_7p_r3 Folder/Obam_9781524763138_all_p_r3.indd
Obam_9781524763138_all_7p_r3 Folder/Obam_9781524763138_all_xp_r3.indd
Obam_9781524763138_all_7p_r3 Folder/Obam_9781524763138_all_77p_r3.qxp";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}