#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "https://(int.|dev.)?example\.com(.*)"
Local $sString = "https://int.example.com/lmds"
Local $sSubst = "https://www.${1}example.com${2}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)