package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`https://(int.|dev.)?example\.com(.*)`)
var str = `https://int.example.com/lmds`
var substitution = "https://www.${1}example.com${2}"
fmt.Println(re.ReplaceAllString(str, substitution))
}