package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+[a-zA-Z]`)
var str = `Service code 145b is used for.
...you are to use code 99a.
Service code 32d is used for.
...you are to use code 119z.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}