$re = '/\d+[a-zA-Z]/m';
$str = 'Service code 145b is used for.
...you are to use code 99a.
Service code 32d is used for.
...you are to use code 119z.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);