re = /\d+[a-zA-Z]/m
str = 'Service code 145b is used for.
...you are to use code 99a.
Service code 32d is used for.
...you are to use code 119z.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end