use strict;
my $str = '1234 1234 1234 1234aas
1234 12344321 1234
1234123443211234
1234 1234 4321 1234';
my $regex = qr/\b\d{4}\s*\d{4}\s*\d{4}\s*\d{4}\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}