# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?xi)^( (DE)?[0-9]{9}|)$"
test_str = ("ATU99999999\n"
"BE0999999999\n"
"BG999999999\n"
"HR12345678901\n"
"CY99999999L\n"
"CZ12345678\n"
"DK99999999\n"
"EE123456789\n"
"FI99999999\n"
"FRXX999999999\n"
"DE999999999\n"
"EL123456789\n"
"HU12345678\n"
"IE1S23456L\n"
"IE1234567T\n"
"IE1234567TW\n"
"IE1234567FA\n"
"ESA12345678\n"
"ESZ1234567E\n"
"DE813992525")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.