package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^t([^t].*)?y$`)
var str = `ty
tytyyayy
tty
tyt`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}