#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:font-family:|https?:\/\/)[^\s\'";}]*(*SKIP)(*FAIL)(media)"
Local $sString = "#mediator .media" & @CRLF & _
"amedias media lorem ipsumedia ar" & @CRLF & _
"{ el : "https://twitter.com/intent/medias/" } Amedia" & @CRLF & _
".element{ font-family: media} .media"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")